Jump to content
metin2dev
  • 0
Traceur3RUN

socket_tcp_bind: tcp_socket: Can't assign requested address

Question

hi how to fix this on source game 40k....

 

FreeBSD 9.2 64

 

line source: mainline_released/mainline_sg

 

game/auth:socket_tcp_bind: tcp_socket: Can't assign requested address

 

 

 

 

more information:

- game 40k (my own compile) dont work

- game 28k work fine

Share this post


Link to post
Share on other sites

46 answers to this question

Recommended Posts

  • 0

ifocnfig

then add the ip to the auth CONFIG file as mentioned above. (BIND_IP: YOUR_SERVER_IP)

 

arleady have

 

Your ip start with 192. Or 10.?

I think problem is from internal ip

yes 192.

Share this post


Link to post
Share on other sites
  • 0

Try this..

 

Open config.cpp and search this

if (!strncmp(netip, "192.168", 7)) // ignore if address is starting with 192

 

change with 

 

if (!strncmp(netip, "999.999", 7))

Share this post


Link to post
Share on other sites
  • 0

Try this..

 

Open config.cpp and search this

if (!strncmp(netip, "192.168", 7)) // ignore if address is starting with 192

 

change with 

 

if (!strncmp(netip, "999.999", 7))

i 2 day ago try this not work  :(

Share this post


Link to post
Share on other sites
  • 0

 

more information:

- game 40k (my own compile) dont work

- game 28k too dont work

 

game100% i test game 28k and working fine lol

I don't get it ._.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

not solved... 

you fix nothing working i see it on clean config.cpp too work on 192.168.xxx

i need fix to BIND_IP: (PUBLIC IP) 

 

 

Reboot, on 02 Jan 2015 - 19:24, said:
show me a photo print of FreeBSD network configuration. 

 network configuration is okey i test on game 28k and work fine.....

Share this post


Link to post
Share on other sites
  • 0

not solved... 

you fix nothing working i see it on clean config.cpp too work on 192.168.xxx

i need fix to BIND_IP: (PUBLIC IP) 

 

 

Reboot, on 02 Jan 2015 - 19:24, said:

show me a photo print of FreeBSD network configuration. 

 network configuration is okey i test on game 28k and work fine.....

lol man all of the posters here asked you about the problem you just say "is okay i tested it"

 

at least show us photos to help you otherwise try on your own

Share this post


Link to post
Share on other sites
  • 0

 

not solved... 

you fix nothing working i see it on clean config.cpp too work on 192.168.xxx

i need fix to BIND_IP: (PUBLIC IP) 

 

 

Reboot, on 02 Jan 2015 - 19:24, said:

show me a photo print of FreeBSD network configuration. 

 network configuration is okey i test on game 28k and work fine.....

lol man all of the posters here asked you about the problem you just say "is okay i tested it"

 

at least show us photos to help you otherwise try on your own

 

i test it not work .......  <_<  i put BIND_IP: (public ip) and have socket_tcp_bind: tcp_socket: Can't assign requested address if you want i can give you tv and you see..... if you dont believe  -_-

 

up i have modem not router...

Share this post


Link to post
Share on other sites
  • 0

 

 

not solved... 

you fix nothing working i see it on clean config.cpp too work on 192.168.xxx

i need fix to BIND_IP: (PUBLIC IP) 

 

 

Reboot, on 02 Jan 2015 - 19:24, said:

show me a photo print of FreeBSD network configuration. 

 network configuration is okey i test on game 28k and work fine.....

lol man all of the posters here asked you about the problem you just say "is okay i tested it"

 

at least show us photos to help you otherwise try on your own

 

i test it not work .......  <_<  i put BIND_IP: (public ip) and have socket_tcp_bind: tcp_socket: Can't assign requested address if you want i can give you tv and you see..... if you dont believe  -_-

 

up i have modem not router...

 

Man, sorry to say you're wrong? Not to offend you?
 
I told you that BIND_IP correct solution.
 
Add me on skype and I show you, it works.
  • Like 1

Share this post


Link to post
Share on other sites
  • 0

 

 

 

not solved... 

you fix nothing working i see it on clean config.cpp too work on 192.168.xxx

i need fix to BIND_IP: (PUBLIC IP) 

 

 

Reboot, on 02 Jan 2015 - 19:24, said:

show me a photo print of FreeBSD network configuration. 

 network configuration is okey i test on game 28k and work fine.....

lol man all of the posters here asked you about the problem you just say "is okay i tested it"

 

at least show us photos to help you otherwise try on your own

 

i test it not work .......  <_<  i put BIND_IP: (public ip) and have socket_tcp_bind: tcp_socket: Can't assign requested address if you want i can give you tv and you see..... if you dont believe  -_-

 

up i have modem not router...

 

Man, sorry to say you're wrong? Not to offend you?
 
I told you that BIND_IP correct solution.
 
Add me on skype and I show you, it works.

 

okey. with BIND_IP: 192.168.xxx work but not work 100% public ip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×